AWS us-east-1 outage impacting cluster operations and backups

Incident Report for CockroachDB Cloud

Resolved

The earlier AWS outage in the us-east-1 region has been fully resolved. All CockroachDB Cloud operations, including cluster creation, scaling, and backups, are functioning normally again.
We’ve verified recovery across affected systems and customer clusters, and normal operations have resumed.
Posted Oct 21, 2025 - 14:56 UTC

Monitoring

AWS has resolved the underlying outage in the us-east-1 region, and we’re seeing recovery across CockroachDB Cloud operations. Cluster creation, scaling, and backups are now succeeding again. We’re continuing to monitor for full stability before marking this incident as resolved.
Posted Oct 20, 2025 - 22:52 UTC

Identified

We’re currently impacted by an ongoing AWS outage in the us-east-1 region. Customers may experience failures or delays when creating new clusters, adding nodes, or running backups in this region. Existing clusters remain operational, but backup operations may be delayed or fail intermittently.
We’re continuing to monitor AWS recovery efforts and will provide updates as more information becomes available.
Posted Oct 20, 2025 - 13:28 UTC