Connectivity issues to CockroachCloud Free clusters
Incident Report for CockroachDB Cloud
Postmortem

All customers connecting to CockroachCloud Free clusters with sslmode=verify-full (the default) lost the ability to connect for about twelve hours. The TLS certificate in use by the SQL gateways expired, and the systems responsible for renewing the certificate were not functioning properly. Customers could again connect once we manually renewed the certificates.

We are working to repair our automated certificate renewal systems, and we have scheduled work to improve the monitoring of certificate expiration.

Thank you for your patience during this outage.

Posted Apr 08, 2021 - 21:56 UTC

Resolved
This incident has been resolved.
Posted Apr 05, 2021 - 21:43 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 05, 2021 - 21:14 UTC
Investigating
We are currently investigating TLS issues while connecting to CockroachCloud Free clusters.
Posted Apr 05, 2021 - 20:37 UTC
This incident affected: CockroachDB Cloud Console.