GCP us-west2 is experiencing a networking & compute incident, leading to networking issues with CC clusters hosted in us-west2
Incident Report for CockroachDB Cloud
Resolved
The incident with Google Cloud in the us-west2 region has been resolved.
Posted May 05, 2021 - 04:57 UTC
Update
The GCP incident in us-west2 is still ongoing: https://status.cloud.google.com/incidents/eCPQKkKcFy6NYXExnPXL. We repeat that one concrete symptom we have observed is that establishing new SQL connections to affected clusters via the public load balancers we expose may fail ~33% of the time.

Please reach out to technical support if find yourself affected & need immediate assistance.
Posted May 05, 2021 - 03:53 UTC
Investigating
We are affected by a GCP incident in us-west2. See here:

- https://status.cloud.google.com/incidents/pfqhuuw5jMhMkPfqd5WC
- https://status.cloud.google.com/incidents/pxD6QciVMd9gLQGcREbV
- https://status.cloud.google.com/incidents/eCPQKkKcFy6NYXExnPXL

The impact is that CC clusters hosted in us-west2 may have networking issues. One concrete symptom we observe is that establishing new SQL connections to affected clusters via the public load balancers we expose fails ~33% of the time. For these clusters, the CC console is also in a degraded state.

GCP has not reported any workarounds yet.
Posted May 05, 2021 - 02:39 UTC
This incident affected: CockroachDB Cloud Console and GCP (Google Cloud Platform Google Compute Engine).