Modifying cluster topology to existing AWS clusters may get stuck
Incident Report for CockroachDB Cloud
Resolved
This incident has been resolved. If you are still experiencing problems with modifying AWS clusters please reach out to support.
Posted Oct 16, 2022 - 10:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 16, 2022 - 02:49 UTC
Update
We are still working on a fix, another update will be provided within 12 hours.
Posted Oct 15, 2022 - 16:54 UTC
Identified
Some existing AWS clusters are impacted by an issue that may prevent them from having their cluster topology modified (i.e. adding/removing nodes and changing the instance type/vCPU count of nodes). This does not affect reachability to clusters nor the creation of new clusters. There is no risk to loss of reachability or availability when attempting to edit existing clusters. If you are impacted by this problem, your cluster will appear to be stuck in an "UPDATING" state without making progress. Please reach out to support if you are impacted and have an urgent need to edit your clusters. We are working on a fix and an update will be provided within 12 hours.
Posted Oct 15, 2022 - 03:14 UTC
This incident affected: CockroachDB Dedicated.