Upstream cloud provider API is unavailable

Incident Report for CockroachDB Cloud

Resolved

Google has reported that mitigations have been applied and services are now recovering.
Posted Jun 12, 2025 - 21:31 UTC

Monitoring

Google has updated their public status page to indicate the underlying issue is resolved, and individual Google Cloud services are in the process of restoring full service. We are continuing to monitor the issue and impact to CockroachDB Cloud.
Posted Jun 12, 2025 - 19:54 UTC

Update

In addition to cluster operations, backups to Google Cloud Storage, including managed backups from CockroachDB Cloud clusters on GCP, may be impacted.
Posted Jun 12, 2025 - 19:08 UTC

Identified

We are aware of errors in the Google Cloud API which may impact cluster creation and edit operations for CockroachDB Cloud Advanced clusters in GCP. We will update this status page with more information as it becomes available.
Posted Jun 12, 2025 - 18:22 UTC
This incident affected: CockroachDB Advanced.