Dependent Service incident intermittently impacting CockroachCloud Operations

Incident Report for CockroachDB Cloud

Resolved

LetsEncrypt has indicated the issue has been mitigated. We have validated cluster creation behaviour is now returning to normal.
Posted Jul 22, 2025 - 04:22 UTC

Identified

We are aware of an ongoing Incident with dependent service "Let's Encrypt": https://letsencrypt.status.io/, which may impact cluster creation and add region operations for CockroachDB Cloud Advanced clusters. We will update this status page with more information as it becomes available.
Posted Jul 21, 2025 - 21:39 UTC
This incident affected: CockroachDB Advanced.