Cluster Creation Failure

Incident Report for CockroachDB Cloud

Resolved

The cluster creation issue has been restored. Issue is resolved.
Posted Jul 12, 2026 - 21:24 UTC

Investigating

We are currently aware of and investigating a cluster creation failure. Teams are engaged and actively working to mitigate as quickly as possible.
Posted Jul 12, 2026 - 20:08 UTC
This incident affected: CockroachDB Basic/Standard.