Google Kubernetes incident impacting cluster operations in GCP.

Incident Report for CockroachDB Cloud

Resolved

Google has reported the issue has been resolved and we've verified cluster operations are functional.
Posted Sep 24, 2025 - 16:00 UTC

Identified

We are currently experiencing an incident impacting certain cluster operations on Google Cloud Platform due to an known ongoing Google Kubernetes-related issue. Customers may encounter errors when creating or editing clusters. Our engineering teams are actively monitoring the situation and communicating with Google regarding resolution.
Posted Sep 24, 2025 - 12:31 UTC
This incident affected: CockroachDB Advanced.