We have resolved the underlying issue that was preventing cluster creation and other cluster operations. We have re-enabled cluster creation on all clouds. We will monitor the situation to ensure that everything continues to operate normally.
Posted Oct 31, 2025 - 20:18 UTC
Update
We are continuing to work on a fix for this issue. Next update will be by 4:30 PM US/Eastern time.
Posted Oct 31, 2025 - 19:58 UTC
Update
We are continuing to work on a fix for this issue. Next update will be by 4:00 PM US/Eastern time.
Posted Oct 31, 2025 - 18:59 UTC
Identified
We have identified the cause of cluster creation failures impacting Basic and Standard AWS clusters. As a precautionary measure, while we apply a fix, we have disabled all cluster creation in Cockroach Cloud. We will restore cluster creation when it is safe to do so. There is no SQL availability impact to any existing clusters. We will update here by 3:00 PM US/Eastern with more information.
Posted Oct 31, 2025 - 18:22 UTC
Update
We are investigating errors with Basic and Standard clusters on AWS. Cluster creation, certain cluster edit operations (such as adding a region), and certain CockroachDB Cloud Console functionality (such as listing databases or users) are also impacted. Basic and Standard clusters on GCP are operating normally at this time.
Posted Oct 31, 2025 - 16:21 UTC
Investigating
We are investigating errors that are causing delays in creation of Basic and Standard clusters on AWS. Basic and Standard cluster creation on GCP is operating normally at this time.
Posted Oct 31, 2025 - 15:54 UTC
This incident affected: CockroachDB Basic/Standard.