Some AWS clusters not showing available backups on the "Backup and Restore" page

Incident Report for CockroachDB Cloud

Resolved

We have deployed a fix which has resolved the issue.
Posted Sep 18, 2024 - 21:33 UTC

Identified

We have identified an issue where some AWS clusters are unable to list available backups on the "Backups and Restore" page. Backups are still being performed and available if a restore of a database or table is required.
Posted Sep 18, 2024 - 19:24 UTC
This incident affected: CockroachDB Advanced.