Issue impacting Basic and Standard tier cluster creation in AWS.

Incident Report for CockroachDB Cloud

Resolved

We have identified and rolled out a fix for the issue impacting cluster creation in AWS. This incident is now resolved.
Posted Jun 27, 2025 - 22:36 UTC

Identified

We have identified an issue impacting Basic and Standard tier cluster creation in AWS. We have conducted an initial investigation and actively working to resolve the issue.
Posted Jun 27, 2025 - 22:29 UTC
This incident affected: CockroachDB Basic/Standard.