Region removal is temporarily disabled
Incident Report for CockroachDB Cloud
Resolved
This incident has been resolved. Customers can again delete regions from their clusters.
Posted Aug 18, 2022 - 23:04 UTC
Identified
We identified an edge case in cluster editing that arises in a narrow category of requested changes. We are implementing stricter validation to exclude the edge case.
Posted Aug 18, 2022 - 19:15 UTC
Investigating
We are investigating a problem with region removal, and we have temporarily disabled it. Region addition is still enabled. Apart from losing the ability to remove regions, CockroachDB Dedicated and Serverless clusters are unaffected.
Posted Aug 18, 2022 - 17:26 UTC
This incident affected: CockroachDB Cloud Console.