Degraded performance in one AWS us-east-1 availability zone

Incident Report for CockroachDB Cloud

Update

AWS reports continued progress towards resolving the issue in the US-EAST-1 Region and is working towards full recovery. Affected services may continue to experience elevated error rates and latencies until recovery is complete. We continue to monitor the situation and take appropriate action to ensure uptime and availability for CockroachDB clusters. We'll provide another update as we learn more from AWS.
Posted May 08, 2026 - 08:25 UTC

Update

AWS's latest status update reports that they are continuing to work on the situation, and progress is slow. AWS has advised a next update time at 05:00 UTC. We continue to monitor the situation and take appropriate action to ensure uptime and availability for Cockroach DB clusters. We'll next update by about 05:00 UTC when we learn more from AWS.
Posted May 08, 2026 - 03:24 UTC

Monitoring

AWS is experiencing elevated error rates and degraded performance in a single availability zone in the us-east-1 region. CockroachDB clusters in us-east-1 remain available, and we are monitoring the situation and taking corrective action as appropriate to ensure SQL availability of CockroachDB clusters in this region.
Posted May 08, 2026 - 02:13 UTC
This incident affects: CockroachDB Advanced.